הדפסה
כניסות: 6630

לאחרונה נאלצתי למלא טופס פניות נהגים של המשטרה בשביל להמיר דו"ח להתראה.

לתדהמתי ממשלת ישראל מחייבת למלא טפסים באינטרנט רק על גבי אקספלורר ופיירפוקס. כרום וספארי נאלצים להישאר בחוץ (מזכיר ימים נוראים).

אצתי רצתי למלא את הטופס אך הפלאגין של פיירפוקס לא עבד וקיבלתי את ההודעה:

The AGForm's extension binary component isn't installed. This means forms won't work correctly.
* Did you install the right package for you platform?

לא הבנתי מה בדיוק התקלה כי מדובר בפלאגין  של תהיל"ה (תשתית הממשלה לעידן האינטרנט) וגם לא הבנתי - אם הזכויות שמורות לממשלת ישראל, האם לי כאזרח מדינת ישראל יש זכות לראות את הקוד מקור?

בכל אופן, פניתי לתהיל"ה ולאחר שבועיים שחיכיתי ולאחר שכבר התקנתי חלונות בסביבה וירטואלית כדי להדפיס טופס של ממשלתי היקרה, חזרו אלי מתהיל"ה. ציינו בפניי כי אמור להיות קובץ so במיקום הבא:

~/.mozilla/firefox/7bwrkkjx.default/extensions/{75364a75-0650-4ca5-8ad1-d525dc17a1e4}/components/ff26/linux

הקובץ אכן היה אך הם לא ידעו להסביר עדיין למה זה לא עובד. אז בדקתי תלויות של אותו קובץ so:

~/.mozilla/firefox/7bwrkkjx.default/extensions/{75364a75-0650-4ca5-8ad1-d525dc17a1e4}/components/ff26/linux$ readelf -d libagat-x86_64.so 
readelf: Error: 'will': No such file
File: libagat-x86_64.so
Dynamic section at offset 0x21d08 contains 28 entries:
Tag Type Name/Value
0x0000000000000001 (NEEDED) Shared library: [libcrypto++.so.9]
0x0000000000000001 (NEEDED) Shared library: [libcrypto.so.1.0.0]
0x0000000000000001 (NEEDED) Shared library: [libz.so.1]
0x0000000000000001 (NEEDED) Shared library: [libxul.so]
0x0000000000000001 (NEEDED) Shared library: [libnspr4.so]
0x0000000000000001 (NEEDED) Shared library: [libmozalloc.so]
0x0000000000000001 (NEEDED) Shared library: [libstdc++.so.6]
0x0000000000000001 (NEEDED) Shared library: [libgcc_s.so.1]
0x0000000000000001 (NEEDED) Shared library: [libc.so.6]
0x000000000000000c (INIT) 0xaaf8
0x000000000000000d (FINI) 0x17308
0x000000006ffffef5 (GNU_HASH) 0x1f0
0x0000000000000005 (STRTAB) 0x1c10
0x0000000000000006 (SYMTAB) 0x260
0x000000000000000a (STRSZ) 9498 (bytes)
0x000000000000000b (SYMENT) 24 (bytes)
0x0000000000000003 (PLTGOT) 0x221fe8
0x0000000000000002 (PLTRELSZ) 3840 (bytes)
0x0000000000000014 (PLTREL) RELA
0x0000000000000017 (JMPREL) 0x9bf8
0x0000000000000007 (RELA) 0x4450
0x0000000000000008 (RELASZ) 22440 (bytes)
0x0000000000000009 (RELAENT) 24 (bytes)
0x000000006ffffffe (VERNEED) 0x4350
0x000000006fffffff (VERNEEDNUM) 6
0x000000006ffffff0 (VERSYM) 0x412a
0x000000006ffffff9 (RELACOUNT) 562
0x0000000000000000 (NULL) 0x0

לאחר גיגול קצר מצאתי את הפוסט הזה שמתקין את התלויות הנ"ל (תחת אובונטו):

$ sudo apt-get install libssl1.0.0 libssl-dev libcrypto++9 libcrypto++-dev

לאחר התקנה הפלאגין בפיירפוקס עבד ויכולתי למלא את הטופס, למרות שלא הייתי זקוק לו ומקווה שלא אזדקק למלא את הטופס הספציפי הזה יותר.

מקווה שזה יעזור למישהו :)

הוספת תגובה

0
  • לא נמצאו תגובות
Powered by Komento